Networks, devices, and sensors · GraphQL type

UpnpIcon type

Icon to depict device in a control point UI. Is allowed to have a different value depending on language requested (see ACCEPT-LANGUAGE and CONTENT-LANGUAGE header fields). Icon sizes to support are vendor-specific.

Fields

Field Name Description
mimetype - String! Icon's MIME type (see RFC 2045, 2046, and 2387). At least one icon should be of type “image/png” (Portable Network Graphics, see IETF RFC 2083).
width - Int! Horizontal dimension of icon in pixels.
height - Int! Vertical dimension of icon in pixels.
depth - Int! Number of color bits per pixel.
url - String Pointer to icon image available via HTTP from the UPnP vendor. Shall be relative to the URL at which the device description is located in accordance with clause 5 of RFC 3986. Specified by UPnP vendor.

Used by

  • UpnpDevice type: Universal Plug and Play (UPnP) logical device advertises its presence and the services it provides on the network(s).

Example

Example

{
  "mimetype": "xyz789",
  "width": 123,
  "height": 987,
  "depth": 987,
  "url": "xyz789"
}